Помогите пожалуйста написать программу! Найти сумму чётных чисел в интервале от А до В ( А и В - натуральные числа, А меньше В).

Помогите пожалуйста написать программу! Найти сумму чётных чисел в интервале от А до В ( А и В - натуральные числа, А< В).
Гость
Ответ(ы) на вопрос:
Гость
var a,b,i,sum: integer;  begin  write ('Введите границы интервала: '); read (a,b);  for i:= a to b do  if i mod 2 = 0 then sum:=sum + i; writeln ('Сумма четных чисел в интервале от А до Б = ',sum); end.
Гость
uses Crt;  var a, b, temp, i, S:integer;  begin  ClrScr;  Write (' a = ');   ReadLn(a);  Write (' b = ');   ReadLn(b);  S:=0;  i:=a;  while i<=b do    begin      if (i mod 2 = 0) then S:=S+i;      i:=i+1;    end;  WriteLn(' S = ', S);  ReadLn;  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы