Помогите пожалуйста написать программу, вычисляющую и сохраняющую в одномерном массиве значение функции у={x при х≤0, х² при х больше 5,4 если иначе. на интервале [-10;10] с шагом 0,5. на Паскале или Си/Си++ Заранее спасибо
Помогите пожалуйста написать программу, вычисляющую и сохраняющую в одномерном массиве значение функции
у={x при х≤0, х² при х>5,4 если иначе. на интервале [-10;10] с шагом 0,5. на Паскале или Си/Си++
Заранее спасибо
Ответ(ы) на вопрос:
{41 = (20/0.5+1}}
var a:array [1..41] of real;
h,y,x:real;
i:integer;
begin
x:=-10.5;
h:=0.5;
i:=0;
repeat
i:=i+1;
y:=4;
if x<=0 then y:=x
else if x>5 then y:=x*x;
a[i]:=y;
x:=x+h;
writeln(x:8:2,a[i]:8:2);
until x>=10;
end.
Не нашли ответ?
Похожие вопросы