Помогите пожалуйста написать программу)))Даны два числа. Наименьшее из этих чисел возвести в квадрат, наибольшее в куб. Найти среднее арифметическое полученных данных.
Помогите пожалуйста написать программу)))
Даны два числа. Наименьшее из этих чисел возвести в квадрат, наибольшее в куб. Найти среднее арифметическое полученных данных.
Ответ(ы) на вопрос:
program gt;
var a,b,s,q:real;
begin
readln(a,b);
q:=0;
if(a>b)then begin
a:=a*a*a;
b:=b*b;
q:=1;
end;
if(q=0)then begin
b:=b*b*b;
a:=a*a;
end;
s:=(a+b)/2;
writeln(a,' ',b,' ',s);
end.
Не нашли ответ?
Похожие вопросы