Помогите пожалуйста. Напишите программу, которая возводит введённое число в степень 10, используя только операции сложения и умножения. Что произойдёт, если ввести большое число 78?
Помогите пожалуйста. Напишите программу, которая возводит введённое число в степень 10, используя только операции сложения и умножения. Что произойдёт, если ввести большое число 78?
Ответ(ы) на вопрос:
var
n,p2,p8,r:integer;
begin
Write('Введите целое число: ');
Read(n);
p2:=n*n; { n^2 }
p8:=p2*p2; { n^4 }
p8:=p8*p8; { n^8 }
r:=p2*p8; { n^10 }
Writeln(r)
end.
Контрольные решения
Введите целое число: 2
1024
Введите целое число: 5
9765625
Введите целое число: 78
605996032
(на самом деле должно быть 8335775831236199424)
Не нашли ответ?
Похожие вопросы