Помогите, пожалуйста, найти ошибки и доделать программу! Задание: Для приведенной ниже функции напишите программу, вычисляющую значение функции в заданной точке x . // isvc.cpp: определяет точку входа для консольного приложени...

Помогите, пожалуйста, найти ошибки и доделать программу! Задание: Для приведенной ниже функции напишите программу, вычисляющую значение функции в заданной точке x . // isvc.cpp: определяет точку входа для консольного приложения. // #include "stdafx.h" #include #include using namespace std; int main() { double x, y, p; const double PI = 3.14159265; setlocale (LC_ALL, "rus_rus.1251"); cout <<" Введите значение х, в котором будет найдено значение функции "<< endl; cin >> x; { if(fabs(x)>=-2 && fabs(x)<0) return exp(2*x)-1; if(fabs(x)>=0 && fabs(x) return sin(x); if(fabs(x)>=PI/2 && fabs(x)<=6 return 1; } cout << " Значение функции в точке х равно "; cout << y < system("pause"); return 0; }
Гость
Ответ(ы) на вопрос:
Гость
#include #include using namespace std; int main(){ double x, y, p; const double PI = 3.14159265; setlocale(LC_ALL, "rus_rus.1251"); cout << "Введите значение х, в котором будет найдено значение функции "; cin >> x; if (fabs(x) >= -2 && fabs(x) < 0) y = exp(2 * x) - 1; if (fabs(x) >= 0 && fabs(x)) y = sin(x); if (fabs(x) >= PI / 2 && fabs(x) <= 6) y = 1; cout << "Значение функции в точке х равно "; cout << y << endl; system("pause"); return 0;}
Не нашли ответ?
Ответить на вопрос
Похожие вопросы