Помогите, пожалуйста. Нужно написать программу суммы двух факториалов, используя цикл(ы). program название; var переменные: integer; begin writeln('введите число') readln(f) for i:= а вот дальше не знаю, как...
Помогите, пожалуйста.
Нужно написать программу суммы двух факториалов, используя цикл(ы).
program название;
var переменные: integer;
begin
writeln('введите число')
readln(f)
for i:=
а вот дальше не знаю, как...
Ответ(ы) на вопрос:
Гость
program factorial;
var n,s:integer;
readln(n);
if (n=0) then writeln('0!=1') else
if (n<0) then writeln('Определяется только для положительных чисел') else
begin
s:=1;
for i:=1 to n do
s:=s*i;
writeln(n,'!='s:0:0);
end;
Не нашли ответ?
Похожие вопросы