Помогите пожалуйста!!!! Нужно составить программу на паскале: Дано три числа. Найти количество положительных чисел среди них
Помогите пожалуйста!!!! Нужно составить программу на паскале: Дано три числа. Найти количество положительных чисел среди них
Ответ(ы) на вопрос:
var
a,b,c:real;
k:integer;
begin
Write('Введите три числа через пробел: '); Read(a,b);
k:=0;
if a>0 then Inc(k);
if b>0 then Inc(k);
if c>0 then Inc(k);
Writeln('Количество отрицательных чисел ',k)
end.
Пример
Введите три числа через пробел: 23.5 -24 0
Количество отрицательных чисел 1
program zadacha;
var
a: array[1..3] of real;
i,k: integer;
begin
k:=0;
writeln('vvedite 3 chisla');
for i:=1 to 3 do read(a[i]);
for i:=1 to 3 do begin
if a[i]>0 then k:=k+1;
end;
writeln('kol-vo polojit.chisel =',k);
end.
Не нашли ответ?
Похожие вопросы