ПОМОГИТЕ  ПОЖАЛУЙСТА ОЧЕНЬ ОЧЕНЬ НАДО !!!1.Составьте программу двух обыкновенных дробей (с клавиатуры должны вводиться их числители и знаменатели ).2.Составьте программу, позволяющую выяснить, есть ли у N два простых делителя.3...

ПОМОГИТЕ  ПОЖАЛУЙСТА ОЧЕНЬ ОЧЕНЬ НАДО !!! 1.Составьте программу двух обыкновенных дробей (с клавиатуры должны вводиться их числители и знаменатели ). 2.Составьте программу, позволяющую выяснить, есть ли у N два простых делителя. 3.Составьте программу, отыскивающую наименьший общий составной делитель  натуральных чисел N и M. 4. Составте программу,  вычесления суммы  четырехзначных чисел, в десятичной записи которых есть два нуля.
Гость
Ответ(ы) на вопрос:
Гость
вот первая var   a1, a2, a3, b1, b2, b3, n : integer; function NOD (a, b : integer) : integer; begin   if b = 0 then NOD := a   else NOD := NOD (b, a mod b); end; begin   write ('Введите первую дробь : '); read (a1, b1);   write ('Введите вторую дробь : '); read (a2, b2);   a3 := a1 * a2;   b3 := b1 * b2;   n := NOD (a3, b3);   a3 := a3 div n;   b3 := b3 div n;   write (a3, '/', b3); end. 
Не нашли ответ?
Ответить на вопрос
Похожие вопросы