Помогите пожалуйста!!! Паскаль!!! Структура цикла: for i:=c to x do begin ...... end i*-переменная(принято принимать ее за i или j) Важно: i может принимать только натуральные значения! c*-число, которое присв...

Помогите пожалуйста!!! Паскаль!!! Структура цикла: for i:=c to x do begin ...... end i*-переменная(принято принимать ее за i или j) Важно: i может принимать только натуральные значения! c*-число, которое присваивается i в начале цикла. x*-число(переменная), достигнув которого, цикл завершит работу. Дано вещественное число A и целое число N (N> 0). Найти A в степени N: AN = A•A•...•A (числа A перемножаются N раз). Входные данные: ввести вещественное число А (-5<=A<=5) и целое число N (1<=n<=10). Выходные данные: вывести A в степени N с точностью до 4 цифр в дробной части. Вещественное число это число типа Real!
Гость
Ответ(ы) на вопрос:
Гость
var n,i:integer; a,an:real; begin write('A = '); readln(a); write('N = '); readln(n); an:=1; for i:=1 to n do an:=an*a; writeln(a,'^',n,' = ',an:6:4); end. Пример: A = 2.1 N = 4 2.1^4 = 19.4481
Не нашли ответ?
Ответить на вопрос
Похожие вопросы