Помогите пожалуйста с 13 задачей (напишите программу,не используя power) огромное спасибо (Pascal ABC )

Помогите пожалуйста с 13 задачей (напишите программу,не используя power) огромное спасибо (Pascal ABC )
Гость
Ответ(ы) на вопрос:
Гость
Сумму членов предложенного ряда можно записать в следующем виде: [latex]\displaystyle S=1+\sum_{i=1}^n(-1)^i \frac{x^{2i}}{(2i)!}=1+\sum_{i=1}^nz_iE_i \\ z_i= \left \{ {{-1, \quad i=1} \atop {-(z_{i-1}), \quad i\ \textgreater \ 1}} \right. \\ E_i= \frac{x^2}{2i(2i-1)} \times E_{i-1}, \quad i\in\mathbb N[/latex] // PascalABC.NET 3.1, сборка 1174 от 22.02.2016 begin   var x:=ReadReal('x=');   var n:=ReadInteger('n=');   var s:=1.0;   var e:=1.0;   var z:=-1;   for var i:=1 to n do begin     e:=e*x*x/(2*i*(2*i-1));     s:=s+z*e; z:=-z     end;   Writeln(s) end. Тестовое решение: x= 0.45 n= 20 0.900447102352677 Для сравнения cos(0.45)≈0.90044710235267692166884061148 С учетом округления последнего разряда все выведенные знаки верны.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы