Помогите пожалуйста! с информатикой Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна.

Помогите пожалуйста! с информатикой Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна.
Гость
Ответ(ы) на вопрос:
Гость
C++: for(int i = 0; i< 20; i++){ a[i]=rand()%101+100; } int pos=0; for(int i = 0; i< 20; i++){ if(a[i]+a[i+1]
Гость
var a:array[1..20] of integer; i,min,ind:integer; begin  randomize; for i:=1 to 20 do begin a[i]:=random(100)+100; write(a[i]:4); end; writeln; min:=a[1]+a[2]; for i:=2 to 19 do if a[i]+a[i+1]
Не нашли ответ?
Ответить на вопрос
Похожие вопросы