Помогите пожалуйста составить программу на Паскале, Использовать неравенства x^2 + y^2 меньше = R^2 если точка принадлежит кругу и x^2 + y^2 больше R^2 в противном случае

Помогите пожалуйста составить программу на Паскале, Использовать неравенства x^2 + y^2 < = R^2 если точка принадлежит кругу и x^2 + y^2 > R^2 в противном случае
Гость
Ответ(ы) на вопрос:
Гость
var x, y, x1, y1, r: real; begin write('Введите координаты точки X, Y: '); read(x, y); write('Введите координаты центра окружности X, Y: '); read(x1, y1); write('Введите радиус окружности R: '); read(r); if sqr(x-x1) + sqr(y-y1) <= r*r then writeln('Точка принадлежит кругу') else writeln('Точка не принадлежит кругу') end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы