Помогите пожалуйста!! Составьте программу в Паскале: Вычислить сумм всех нечётных чисел в интервале от 1 до 2К-1. Заранее ОГРОМНОЕ спасибо Вам!!

Помогите пожалуйста!! Составьте программу в Паскале: Вычислить сумм всех нечётных чисел в интервале от 1 до 2К-1. Заранее ОГРОМНОЕ спасибо Вам!!
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1377 от 19.01.2017 // Внимание! Если программа не работает, обновите версию! begin   var k:=ReadInteger('k=');   Writeln('s=',Range(1,2*k-1,2).Sum) end. Пример k= 4 s=16
Гость
var     k: integer; s: real; begin     readln(k);     s := ((1+(2*k-1))/2)*(((2*k-1)-1)/2+1);     writeln(s); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы