Помогите ,пожалуйста , в с++ Написать программу, которая преобразует введенное с клавиатуры двухразрядное шестнадцатеричное число в десятичное.

Помогите ,пожалуйста , в с++ Написать программу, которая преобразует введенное с клавиатуры двухразрядное шестнадцатеричное число в десятичное.
Гость
Ответ(ы) на вопрос:
Гость
Выбирайте любое решение на ваш вкус, первое немного более топорное.  Решение 1. #include #include int main() {    const std::string numbers = "0123456789ABCDEF";    std::string hex = "";    int dec = 0;    std::cin >> hex;    for(int i = 0; i < hex.length(); i++)       dec = 16 * dec + numbers.find(hex[i]);    std::cout << dec;    return 0; } Решение 2. #include int main() {    int num = 0;    std::cin >> std::hex >> num;    std::cout << num;    return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы