Помогите пожалуйста, я вообще это не понимаю! (язык программирования -Паскаль) Дано 2 целых положительных числа: a и b. Требуется написать программу, которая находит цифру, на которую оканчивается число a^b. Входные данные Резу...
Помогите пожалуйста, я вообще это не понимаю! (язык программирования -Паскаль)
Дано 2 целых положительных числа: a и b. Требуется написать программу, которая находит цифру, на которую оканчивается число a^b.
Входные данные
Результат
a=2
b=4
6
Ответ(ы) на вопрос:
уже третьему пишу
Var A,B,C:integer;
Begin
assign(input,'input.txt');
reset(input);
assgin(output,'outpt');
rewrite(output);
C:=1;
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
For B:= 1 to B do
C:=C*A;
WriteLn(C mod 10);
End.
const
K:array[2..9,1..4] of integer=(
(2,4,8,6),
(3,9,7,1),
(4,6,4,6),
(5,5,5,5),
(6,6,6,6),
(7,9,3,1),
(8,4,2,6),
(9,1,9,1));
var
A,B,i,j:integer;
begin
Write('a='); Read(A);
Write('a='); Read(B);
i:=A mod 10;
if i<2 then Writeln(i)
else begin
j:=B mod 4;
if j=0 then j:=4;
Writeln(K[i,j])
end
end.
Не нашли ответ?
Похожие вопросы