Помогите пожалуйста,на языке PascalABC.Net: 2) Разработать программу циклической структурой в соответствии с предложенным вариантом, используя цикл с предусловием. Дано действительное число х, натуральное число n. Написать прог...

Помогите пожалуйста,на языке PascalABC.Net: 2) Разработать программу циклической структурой в соответствии с предложенным вариантом, используя цикл с предусловием. Дано действительное число х, натуральное число n. Написать программу, которая вычисляет сумму последовательности, заданной формулы x^1/1!+x^2/2!+x^3/3!+...+x^n/n!
Гость
Ответ(ы) на вопрос:
Гость
//PascalABC.NET 3.1 сборка 1239 begin     var x := ReadReal('x =');     var s := 0.0;     var a := 1.0;          for var i := 1 to ReadInteger('n =') do     begin         a *= x / i;         s += a;     end;     writeln(s); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы