ПОМОГИТЕ ПОЖАЛУЙСТА!Напишите программу, которая определяет площадь четырехугольника по известным значениям его 4ех сторон и одной диагонали.
ПОМОГИТЕ ПОЖАЛУЙСТА!
Напишите программу, которая определяет площадь четырехугольника по известным значениям его 4ех сторон и одной диагонали.
Ответ(ы) на вопрос:
По формуле Герона
var a,b,c,d:real;
Begin
readln(a,b,c,d);
writeln( sqrt( ((a+b+c+d)/2-a)*((a+b+c+d)/2-a)*((a+b+c+d)/2-c)*((a+b+c+d)/2-d)));
End.
Не нашли ответ?
Похожие вопросы