Помогите решить. составить программу для выполнения указанного ниже задания,используя оператор множественного ветвления. по номеру класса выдать название школьной ступени.
Помогите решить.
составить программу для выполнения указанного ниже задания,используя оператор множественного ветвления. по номеру класса выдать название школьной ступени.
Ответ(ы) на вопрос:
//Pascal ABC.NET 3.1 сборка 1219
Var
a:integer;
begin
readln(a);
case a of
1..4:writeln('Младшая школа');
5..9:writeln('Средняя школа');
10..11:writeln('Старшая школа')
else writeln('Не класс');
end;
end.
//Dev-C++ 4.9.9.2
#include
using namespace std;
int main(){
setlocale(LC_CTYPE,"Russian");
int a=0;
cin>>a;
switch(a){
case 1:
case 2:
case 3:
case 4:
cout<<"Младшая школа";
break;
case 5:
case 6:
case 7:
case 8:
case 9:
cout<<"Средняя школа";
break;
case 10:
case 11:
cout<<"Старшая школа";
break;
default:
cout<<"Не класс";
break;
}
cin.get();
cin.get();
return 0;
}
Пример ввода:
11
Пример вывода:
Старшая школа
Не нашли ответ?
Похожие вопросы