ПОМОГИТЕ С ИКТ!!! ПАСКАЛЬ! ДАЮ 23 балла! _____________________________ Задача: Вводится последовательность чисел, которая оканчивается 0. Определите количество и сумму чисел, которые кратны B. Если таких чисел нет, то сообщить ...

ПОМОГИТЕ С ИКТ!!! ПАСКАЛЬ! ДАЮ 23 балла! _____________________________ Задача: Вводится последовательность чисел, которая оканчивается 0. Определите количество и сумму чисел, которые кратны B. Если таких чисел нет, то сообщить об этом. (решить нужно с помощью цикла while)
Гость
Ответ(ы) на вопрос:
Гость
//Pascal //вариант с циклом while var   a,b, n: integer; begin   n:=0;     readln(b);     readln(a);     while a<>0 do begin     if a mod b = 0 then n:=n+1;       readln(a);    end;    writeln(n); end.
Гость
var a, b, S, k: integer;beginS:=0;k:=0;readln(b);readln (a);while (a<>0) do beginif (a mod b =0)then begin S:=S+1;k:=k+a;end;readln (a);end;if (S>0) and (k>0)then writeln (S, ' ', k)else writeln ('таких чисел нет');end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы