Помогитe составить программу на Free Pascal. Дано натуральное число. Верно ли, что произведение его цифр не больше 50

Помогитe составить программу на Free Pascal. Дано натуральное число. Верно ли, что произведение его цифр не больше 50
Гость
Ответ(ы) на вопрос:
Гость
Если число не слишком большое, то: var n,p:integer; begin write('n = '); readln(n); p:=1; while n>0 do  begin  p:=p*(n mod 10);  n:=n div 10;  end; if p<=50  then writeln('Произведение цифр числа = ',p,' (<= 50)')  else writeln('Произведение цифр числа = ',p,' (> 50)'); end. Пример: n = 456 Произведение цифр числа = 120 (> 50)
Не нашли ответ?
Ответить на вопрос
Похожие вопросы