Помогите составить задачу в Pascal С клавиатуры вводят строку. Составить программу, которая: a) определит количество символов в ней; b) выведет на экран первый, второй и последний символы; c) выведет на экран коды первого и п...

Помогите составить задачу в Pascal С клавиатуры вводят строку. Составить программу, которая: a) определит количество символов в ней; b) выведет на экран первый, второй и последний символы; c) выведет на экран коды первого и последнего символов строки; ∗ d) проверит, не совпадают ли первый и последний символы строки; ∗ e) определит количество символов в строке чётно или нечётно; ∗ f) проверит, есть ли в ней (в строке) слово «мама».
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.Net 3.0, сборка 1064 var   s:string;   n:integer; begin   Write('Введите строку: '); Readln(s);   // a   n:=Length(s);   Writeln('Количество символов в строке равно ',n);   // b   Writeln(s[1],', ',s[2],', ',s[n]);   // c   Writeln(Ord(s[1]),', ',Ord(s[n]));   // d   if s[1]=s[n] then Writeln('Первый и последний символы совпадают')   else Writeln('Первый и последний символы не совпадают');   // e   if n mod 2 = 0 then Writeln('Количество символов в строке четно')   else Writeln('Количество символов в строке нечетно');   // f   if Pos('мама',s)>0 then Writeln('Строка содержит слово "мама"')   else Writeln('Строка не содержит слово "мама"') end. Тестовое решение: Введите строку: Тестовая строка со словом <мама> внутри Количество символов в строке равно 39 Т, е, и 210, 232 Первый и последний символы не совпадают Количество символов в строке нечетно Строка содержит слово "мама"
Не нашли ответ?
Ответить на вопрос
Похожие вопросы