Помогите в Pascal №4. Дана величина A, выражающая объем информации в мегабайтах. Составьте программу перевода величины А в более мелкие единицы информации. №5. Даны длины сторон треугольника A, B, C. Найти площадь треугольн...
Помогите в Pascal
№4. Дана величина A, выражающая объем информации в мегабайтах. Составьте программу перевода величины А в более мелкие единицы информации.
№5. Даны длины сторон треугольника A, B, C. Найти площадь треугольника S. Составьте программу решения поставленной задачи.
, где р – полупериметр
№6. Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (c).
Ответ(ы) на вопрос:
Гость
4.
var
a:real;
begin
write('Введите количество мегабайт=');read(a);
writeln('Количество килобайт=',a*1024);
writeln('Количество байт=',a*1024*1024);
writeln('Количество бит=',a*1024*1024*8);
end.
5.
var
a,b,c,p,S:real;
begin
write('Введите сторону a=');read(a);
write('Введите сторону b=');read(b);
write('Введите сторону c=');read(c);
P:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
write('S=',s:5:2);
end.
6.
var
a:integer;
begin
write('Введите количество суток=');read(a);
writeln(24*a,' ','часов');
writeln(60*24*a,' ','минут');
writeln(60*60*24*a,' ','секунд');
end.
Не нашли ответ?
Похожие вопросы