Помогите,пожалуйста с программированием..... Решить задачу, составить программу в паскаль и выполнить С помощью датчика случайных чисел заданы два двумерных массива размером 3 строки и 2 столбца. Вычислить третий массив такого ...

Помогите,пожалуйста с программированием..... Решить задачу, составить программу в паскаль и выполнить С помощью датчика случайных чисел заданы два двумерных массива размером 3 строки и 2 столбца. Вычислить третий массив такого же размера, каждый элемент которого равен произведению соответствующих элементов двух первых массивов, уменьшенному в 10 раз. Все массивы вывести
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016 begin   var a:=MatrixRandom(3,2,-99,99);   Writeln('Массив А');   for var i:=0 to 2 do begin     for var j:=0 to 1 do Write(a[i,j]:4);     Writeln     end;   var b:=MatrixRandom(3,2,-99,99);   Writeln('Массив B');   for var i:=0 to 2 do begin     for var j:=0 to 1 do Write(b[i,j]:4);     Writeln     end;   var c:array[0..2,0..1] of real;   Writeln('Результирующий массив');   for var i:=0 to 2 do begin     for var j:=0 to 1 do begin       c[i,j]:=a[i,j]*b[i,j]/10; Write(c[i,j]:7:1)       end;     Writeln     end end. Тестовое решение Массив А  -91 -93  -62   9  -97   6 Массив B  -64  18   57 -34  -65 -30 Результирующий массив   582.4 -167.4  -353.4  -30.6   630.5  -18.0
Не нашли ответ?
Ответить на вопрос
Похожие вопросы