ПОМОГИТЕ,ПОЖАЛУЙСТА,очень срочно нужно написать программу в Pascal(ABC)
ПОМОГИТЕ,ПОЖАЛУЙСТА,очень срочно
нужно написать программу в Pascal(ABC)
Ответ(ы) на вопрос:
Гость
Программа для случая, когда слова отделяются друг от друга одним пробелом:
var
s,s1,s2,smax:string; c:char; p,k,i,max:integer;
begin
writeln('Введите строку:');
readln(s);
writeln('Введите букву:');
readln(c);
s1:=s+' ';
max:=0;
p:=pos(' ',s1);
while p>0 do
begin
s2:=copy(s1,1,p-1);
k:=0;
for i:=1 to length(s2) do
if s2[i]=c then k:=k+1;
if k>max then begin max:=k; smax:=s2; end;
delete(s1,1,p);
p:=pos(' ',s1);
end;
writeln('smax = ',smax);
end.
Пример:
Введите строку:
строку и букву нужно ввести самостоятельно с клавиатуры
Введите букву:
о
smax = самостоятельно
Не нашли ответ?
Похожие вопросы