Пожалуйста помогите с информатикой))) нужно написать программу для паскаля возведения числа а в степень n/

Пожалуйста помогите с информатикой))) нужно написать программу для паскаля возведения числа а в степень n/
Гость
Ответ(ы) на вопрос:
Гость
program stepen; uses crt; var a,n,i,p : integer; begin write('Введите число a='); readln(a); write('Введите степень числа n='); readln(n); p:=1; for i:=1 to n do p:=p*a; write('Число а в степени n = ',p) end.
Гость
program zadacha; var a,b,c : integer; begin c:=1; write('Введите число ==> '); readln(a); write('Введите его степень ==> '); readln(b); while b<>0 do begin c:=a*c; b:=b-1; end; write('степень числа ==> ',c); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы