Программирование на C++ Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 меньше = x меньше = 30000). Входные данные Вводится натуральное число x. Выходные данные Выведите наименьший делитель числа x, отл...

Программирование на C++ Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000). Входные данные Вводится натуральное число x. Выходные данные Выведите наименьший делитель числа x, отличный от 1.
Гость
Ответ(ы) на вопрос:
Гость
#include int main() { int n; std::cin >> n; int i = 2; while (n % i > 0) ++i; std::cout << i; return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы