Разработать алгоритм решения задачи, представив его в виде блок-схемы; Составить программу на алгоритмическом языке Turbo Pascal; Вывести результаты расчетов на печать (дисплей). Дана функция, где x изменяется от –4 до 7 с шаго...
Разработать алгоритм решения задачи, представив его в виде блок-схемы;
Составить программу на алгоритмическом языке Turbo Pascal;
Вывести результаты расчетов на печать (дисплей).
Дана функция, где x изменяется от –4 до 7 с шагом h = 0,2.
[latex] y=\left \{ {{2x-5sinx} \atop {1-sinx}} \atop {ln(4x+sinx}}[/latex]
если x < −3 ,
если − 3 ≤ x ≤ 5 ,
если x > 5 .
Вычислить и вывести на экран среднее арифметическое положительных значений у.
Пожалуйста, нужно очень срочно и подробно!
Ответ(ы) на вопрос:
Гость
Var x,y,S:real;
k:integer;
Begin
x:=-4;
k:=0;
While x<7 do
Begin
if (x < -3) then y:=2*x-5*Sin(x)
else if (-3 <= x)and(x <= 5) then y:=1-Sin(x)
else y:=ln(4*x+Sin(x));
if (y > 0) then
Begin
S:=S+y;
k:=k+1
End;
WriteLn('y(',x:0:1,') = ',y:0:3);
x:=x+0.2
End;
WriteLn('Sr = ',S/k);
ReadLn
End.
Не нашли ответ?
Похожие вопросы