Сколько существует трёхзначных чисел сумма цифр которых делится на 5? Вывести их.Программа паскаль
Сколько существует трёхзначных чисел сумма цифр которых делится на 5? Вывести их.
Программа паскаль
Ответ(ы) на вопрос:
var
i, a, k, sum : integer;
begin
k:=0;
for i:=100 to 999 do
begin
sum:=0;
a:=i;
while a>0 do
begin
sum:=sum+(a mod 10);
a:=a div 10;
end;
if sum mod 5 = 0 then
begin
inc(k);
write(i:5);
end;
end;
writeln;
writeln('Количество чисел: ', k);
end.
Не нашли ответ?
Похожие вопросы