Сложное задание по информатике: Нужно написать программу на паскале, не используя if, then, else, с таким результатом: Введите число если число четное, то вывести 10; если нечетное, то вывести -10

Сложное задание по информатике: Нужно написать программу на паскале, не используя if, then, else, с таким результатом: Введите число если число четное, то вывести 10; если нечетное, то вывести -10
Гость
Ответ(ы) на вопрос:
Гость
var a:integer; begin write('a = '); readln(a); writeln(-20*(abs(a) mod 2)+10); end. Пример: a = 28 10
Гость
var n: integer; res: boolean; begin readln(n); res:=odd(n); case res of true: writeln('-10'); false: writeln('10'); end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы