Составить алгоритм и написать программу вычисления площади геометрической фигуры с использованием условного оператора if по одной из формул: S=п*r ; S=a*b
Составить алгоритм и написать программу вычисления площади геометрической фигуры с использованием условного оператора if по одной из формул: S=п*r ; S=a*b
Ответ(ы) на вопрос:
var s,r,a,b:real; k:byte; begin repeat write ('1 - S kruga; 2 - S pryamougolnika: ');readln(k); until (k=1) or (k=2); if k=1 then begin write ('Radius: ');readln(r); s:=pi*r; writeln ('S = ',s:0:5); end else begin write ('A = ');readln(a); write('B = ');readln(b); s:=a*b; writeln ('S = ',s:0:4); end; readln; end.
Не нашли ответ?
Похожие вопросы