Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию. Ввод чисе...

Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию. Ввод чисел заканчивается нажатием клавиши 0. Протокол работы программы: Выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 1 Введите два числа: 15 16 Ответ: 15+16=31 Выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 3 Введите два числа: 5 8 Ответ: 5*8=40 Выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 0 Пока!
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c,x:real; begin  repeat  writeln('Введите тип арифм. операции (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - остановить программу');  readln(x);  if x=1  then   begin    writeln('Введите 2 числа');    readln(a,b);    c:=a+b;    writeln('Ответ: ',c);    end;  if x=2  then   begin    writeln('Введите 2 числа');    readln(a,b);    c:=a-b;    writeln('Ответ: ',c);    end;  if x=3  then   begin    writeln('Введите 2 числа');    readln(a,b);    c:=a*b;    writeln('Ответ: ',c);    end;  if x=4  then   begin    writeln('Введите 2 числа');    readln(a,b);    c:=a/b;    writeln('Ответ: ',c);    end;  if x=0 then writeln('Пока!');  until x=0; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы