Составить программу которая находит количество двузначных чисел фибоначчи которые начиная с заданного номера n при делении на 5 дают в остатке заданное z

Составить программу которая находит количество двузначных чисел фибоначчи которые начиная с заданного номера n при делении на 5 дают в остатке заданное z
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c,n,n2,z:integer; begin  write('введите номер первого числа n ==> ');  readln(n);  write('введите искомый остаток ==> z ');  readln(z);  b:=0;  n2:=0;  a:=1;   while c<100 do begin     c:=a+b;      b:=a;     a:=c;     n2:=n2+1;     if (n2>=n) and (c mod 5 = z) then writeln('нужное число ==> ',c);       end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы