Составить программу на паскаль: Имеются сведения о 40-и регионах страны: название региона и информация об уровне безработицы в регионе. Определите три наиболее благополучных и три неблагополучных района
Составить программу на паскаль: Имеются сведения о 40-и регионах страны: название региона и информация об уровне безработицы в регионе. Определите три наиболее благополучных и три неблагополучных района
Ответ(ы) на вопрос:
a:array[1..40] of string;
b:array[1..40] of integer;{буду считать что информация по безработице-число}
i, n, j, m:integer;
begin
for i:=1 to 40 do
readln(a[i]);
readln(b[i]);
for i:=1 to 40 do
for j:=1 to 40 do
if b[i]>b[j] then begin
n:=a[i]; a[i]:=a[j]; a[j]:=n;
m:=b[i]; b[i]:=b[j]; b[j]:=m; end;
writeln('неблагополучные регионы:');
for i:=1 to 3 do
writeln(a[i],' ',b[i]);
writeln('благополучные регионы:');
for i:=40 downto 38 do
writeln(a[i],' ',b[i]);
readln;
end.
Не нашли ответ?
Похожие вопросы