Составить программу на паскале Дано натуральное число,найти сумму цифр этого числа!

Составить программу на паскале  Дано натуральное число,найти сумму цифр этого числа!
Гость
Ответ(ы) на вопрос:
Гость
Program Program1; var i,sum,n,code:integer; s:string; begin write('Введите натуральноее число: '); readln(s); sum:=0; for i := 1 to Length(s) do begin Val(s[i], n, code); sum:=sum + n; end; writeln('Сумма цифр: ', sum) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы