Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше. Нахождение количество цифр числа оформить в виде функцииРешение на паскале, написать программу
Составить программу, определяющую, в каком из
данных 5 чисел количество цифр больше. Нахождение количество цифр числа
оформить в виде функции
Решение на паскале, написать программу
Ответ(ы) на вопрос:
function len(a: integer): byte;
begin
result := Length(IntToStr(a));
end;
var
a, b: integer;
begin
for i: byte := 1 to 5 do //Убрав цикл, можно сэкономить память, не знаю насчёт ресурсов ЦП, но с циклом красивее
begin
readln(a);
if (len(a) > len(b)) then
b := a;
end;
writeln(b);
end.
Не нашли ответ?
Похожие вопросы