Составить программу, определяющую, все целые числа из промежутка от 300 до 600, у которых сумма делителей кратна 10. Язык: с++; PS: задачу нужно решить при помощи do_while
Составить программу, определяющую, все целые числа из промежутка от 300 до 600, у которых сумма делителей кратна 10.
Язык: с++;
PS: задачу нужно решить при помощи do_while
Ответ(ы) на вопрос:
Гость
#include using namespace std;
int main () { int digit = 300; do { int sum = 0; int teiler = 1; while (teiler <= digit) { if (digit % teiler == 0) sum+=teiler; teiler++; } if(sum % 10 == 0) { cout << digit << endl; } digit++; } while (digit <= 600); return 0; }
Не нашли ответ?
Похожие вопросы