Составить программу, печатающую все простые числа, не превосходящие данного числа. паскаль абс
Составить программу, печатающую все простые числа, не превосходящие данного числа.
паскаль абс
Ответ(ы) на вопрос:
Program Prostoe;
Uses
Crt;
Var
i, {возможный делитель}
Number : integer; {исследуемое число}
Begin
ClrScr;
writeln (‘Какое число должно быть проверено? ‘);
read (Number);
i := 1;
repeat
i := i+1;
until Number mod i = 0;
if Number=i
then
writeln (Number,’ является простым‘)
else
writeln (Number,’ делится на ‘,i);
readln;
End.
Не нашли ответ?
Похожие вопросы