Составить программу, печатающую значение true, если указанное выражение является истинным, и false в противоположном случае. Сумма двух первых цифр задонного четырехзначного числа равна сумме двух его последних цифр. (Примечани...
Составить программу, печатающую значение true, если указанное выражение является истинным, и false в противоположном случае. Сумма двух первых цифр задонного четырехзначного числа равна сумме двух его последних цифр. (Примечание: для решения использовать функцию div).
Ответ(ы) на вопрос:
Гость
var
a:integer;
begin
read(a);
if a div 1000 + a div 100 mod 10 = a mod 100 div 10 + a mod 10 then writeln('true')
else writeln('false');
end.
Не нашли ответ?
Похожие вопросы