Составить программу в Паскале: Если товар сначала подорожал на 10%, а затем подешевел на 10%, то на сколько процентов изменилась цена товара?
Составить программу в Паскале: Если товар сначала подорожал на 10%, а затем подешевел на 10%, то на сколько процентов изменилась цена товара?
Ответ(ы) на вопрос:
Гость
Надеюсь помог..............
Гость
const p1=10; p2=10;
var p:real;
begin
p:=100-(100+p1)*(100-p2)/100;
if p>0
then writeln('Товар подешевел на ',p:3:1,'%')
else writeln('Товар подорожал на ',-p:3:1,'%');
end.
Результат:
Товар подешевел на 1.0%
Не нашли ответ?
Похожие вопросы