Составить программу в Паскале. Заменить в тексте слово "sin" на слово "cos" и подсчитать количество замен.
Составить программу в Паскале.
Заменить в тексте слово "sin" на слово "cos" и подсчитать количество замен.
Ответ(ы) на вопрос:
var y,x: string;
i,k: integer;
begin
k=0;
read (x);
for i:=1 to length(x) do
begin
y:=copy(x, i,3);
If (y='sin') then begin
delete (x, i, 3);
insert ('cos', x, i);
k:=k+1;
end;
writeln (x);
writeln (k);
end.
Не нашли ответ?
Похожие вопросы