Составить программу вычеслений степени числа А с натуральным показателем N. С объяснением ладно .Pascal
Составить программу вычеслений степени числа А с натуральным показателем N. С объяснением ладно .Pascal
Ответ(ы) на вопрос:
Например, вот так: var z:real; a,n:integer;
begin
read(a,n);
z:=exp(n*ln(a));
writeln('z = ',z);readln;
end.
exp(n*ln(a)) - "формула" возведения в степень в паскале (одна из множества возможных), где n и а - произвольные, z не может быть integer
Не нашли ответ?
Похожие вопросы