Составить программу вычисления значений функции F(x) на отрезке [a,b] с шагом h. Резул?
Составить программу вычисления значений функции F(x) на отрезке [a,b] с шагом h. Резул??тат представить в виде таблицы, первых столбец которой – значения аргумента, второй – соответствующие значения функции. Программу составить двумя способами: с использованием цикла с предусловием и с использованием цикла с постусловием. F(x) ctg x+ 1
Ответ(ы) на вопрос:
Гость
Var a,b,h,x,x1,x2:real;
function F(x:real):real;
begin
F:=cos(x)/sin(x)+1;
end;
begin
writeln('Функция: F(x)=ctgx+1');
write('Введите крайние точки отрезка: '); readln(x1,x2);
write('Введите шаг: '); readln(h);
writeln('| x | F(x) |');
writeln('_________________');
if x1>x2 then begin
a:=x2; b:=x1; end
else begin
a:=x1; b:=x2; end;
x:=a;
while x<=b do
begin
writeln('|',x:7:3,'|',f(x):7:3,'|');
x:=x+h;
end;
end.
Не нашли ответ?
Похожие вопросы