Составить программу вычисления функции на языке паскаль (a+b)/ (e^-x+Sin(x)) T={ (a+b)/(x+1) e^-x+Sin(x) условие: x меньше 2.8; 2.8 меньше =x меньше 6; x больше =6 исходные данные: a=2.1; b=-0.29 шаг изменения: ...
Составить программу вычисления функции на языке паскаль (a+b)/ (e^-x+Sin(x)) T={ (a+b)/(x+1) e^-x+Sin(x) условие: x<2.8; 2.8<=x<6; x>=6 исходные данные: a=2.1; b=-0.29 шаг изменения: x принадлежит [0;7]; дельта x=0.5
Ответ(ы) на вопрос:
program lol;
var
a,b,x:real;
shag:real;
T:real;
begin
Shag:=0.5;
a:=2.1;
b:=-0.29;
x:=0;
While x<=7 do
begin
If x<2.8 then
T:=(a+b)/exp(-x)+sin(x);
If (2.8<=x) and (x<6) then
T:=(A+B)/(x+1);
If X>=6 then
t:=exp(-x)+Sin(X);
Writeln('при Х=',x,' T=',t:4:2);
X:=x+shag; end; end. надеюсь помог.Если что нетак пиши
Не нашли ответ?
Похожие вопросы