Составить программу вычисления количества натуральных нечётных чисел сумма квадратов которых не превысит 1000.( на Паскале)
Составить программу вычисления количества натуральных нечётных чисел сумма квадратов которых не превысит 1000.( на Паскале)
Ответ(ы) на вопрос:
Гость
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var
a, s, n: integer;
begin
while s < 1000 do
begin
if a mod 2 <> 0 then begin
s := s + sqr(a);
n := n + 1;
end;
a := a + 1;
end;
writeln(n-1);
end.
Не нашли ответ?
Похожие вопросы