Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b ( от1 до 100). Нужно составить 1- с циклом с пред условием, 2 - с циклом с пост условием
Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b ( от1 до 100).
Нужно составить 1- с циклом с пред условием, 2 - с циклом с пост условием
Ответ(ы) на вопрос:
1)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
for a:=1 to 99 do begin
if a mod b = 0 then
sum:=sum+a;
end;
writeln(sum);
end.
2)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
repeat
if a mod b = 0 then
sum:=sum+a;
inc(a);
until a=100
writeln(sum);
end.
Не нашли ответ?
Похожие вопросы