Составить программу, вычисляющую x^n, где n – целое положительное число. Выполнить в 3-х циклах
Составить программу, вычисляющую x^n, где n – целое положительное
число.
Выполнить в 3-х циклах
Ответ(ы) на вопрос:
Гость
1. Для цикла For
var
x,n,p:longint;
i:integer;
begin
readln (x,n);
p:=1;
for i := 1 to N do
p:=p*x;
writeln(x,' в степени ',n,' равно ',p );
end.
2. Для цикла While
var
x,n,p:longint;
i:integer;
begin
readln (x,n);
p:=1;
i:=1;
while i<=n do begin
p:=p*x;
i:=i+1;
end;
writeln(x,' в степени ',n,' равно ',p );
end.
3. Для цикла Repeat
var
x,n,p:longint;
i:integer;
begin
readln (x,n);
p:=1;
i:=1;
repeat
p:=p*x;
i:=i+1;
until i>n;
writeln(x,' в степени ',n,' равно ',p );
end.
Не нашли ответ?
Похожие вопросы