Составьте алгоритм и напишите программу для того чтобы выяснить является ли введённое шестизначное число счастливым суперсчастливым или обыкновенным. Шестизначное число называют счастливым если сумма первых трёх его цифр равна ...

Составьте алгоритм и напишите программу для того чтобы выяснить является ли введённое шестизначное число счастливым суперсчастливым или обыкновенным. Шестизначное число называют счастливым если сумма первых трёх его цифр равна сумме трёх последних цифр. Число будет называться суперсчастливым если оно во-первых счастливое а во-вторых сумма первых трёх его чисел равна 11 или 22
Гость
Ответ(ы) на вопрос:
Гость
var n:longint; c1,c2:byte; s:boolean; begin s:=false readln(n); c1:=(n mod 10)+((n div 10) mod 10)+((n div 100) mod 10); c2:=((n div 1000) mod 10) + ((n div 10000) mod 10) + ((n div 100000) mod 10); if c1=c2 then s:=true; if s and ((c2=11) or (c2=22)) then writeln('supershastlivoe') else if s then writeln('shaslivoe') else writeln('prostoe'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы