Составьте программу, Которая формирует массив из десяти случайных целых чисел от 100 до 150 и увеличивает в два раза числа, кратные 5, а остальные уменьшает в 2 раза
Составьте программу, Которая формирует массив из десяти случайных целых чисел от 100 до 150 и увеличивает в два раза числа, кратные 5, а остальные уменьшает в 2 раза
Ответ(ы) на вопрос:
Гость
#include
using namespace std;
int main() {
const int SIZE = 10;
int a[SIZE];
size_t i;
for(i = 0; i < SIZE; i++) {
a[i] = rand() % 51 + 100;
cout << "a[" << i << "] = " << a[i] << '\n';
if (a[i] % 5 == 0)
a[i] = 2* a[i];
else
a[i] = (int) a[i]/2;
}
cout << "-----" << '\n';
for(i = 0; i < SIZE; i++) {
cout << "a[" << i << "] = " << a[i] << '\n';
}
return 0;
}
Не нашли ответ?
Похожие вопросы