Составьте программу, которая определяет к какой группе относится введенный символ (с) – к цифрам, заглавным или прописным буквам. На экран должна выводиться фраза «Символ с – это …», где вместо … пишется соответствующая группа ...

Составьте программу, которая определяет к какой группе относится введенный символ (с) – к цифрам, заглавным или прописным буквам. На экран должна выводиться фраза «Символ с – это …», где вместо … пишется соответствующая группа (например, «Символ R – это заглавная буква»).
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016 begin   var c:=ReadlnChar('Введите символ');   case c of   'A'..'Z': Writeln('Символ ',c,'- это прописная латинская буква');   'a'..'z': Writeln('Символ ',c,'- это строчная латинская буква');   'А'..'Я','Ё': Writeln('Символ ',c,'- это прописная русская буква');   'а'..'я','ё': Writeln('Символ ',c,'- это строчная русская буква');   '0'..'9': Writeln('Символ ',c,'- это цифра');   else Writeln('Символ ',c,'- это специальный знак')   end end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы