Составьте программу, определяющую принадлежность точки А(х, у) окружности с центром 0(0; 0) и радиусом R.В паскалеABC.
Составьте
программу, определяющую принадлежность точки А(х, у) окружности с центром
0(0; 0) и радиусом R.
В паскалеABC.
Ответ(ы) на вопрос:
var x,y,r:real;
begin
writeln('Введите радиус окружности');
readln(r);
writeln('Введите координаты точки А');
readln(x,y);
if sqr(x)+sqr(y)=sqr(r) then writeln('Принадлежит')
else writeln('Не принадлежит');
end.
var x,y,r:real;
begin
readln(r);
readln(x,y);
if sqr(x)+sqr(y)<=sqr(r) then
writeln('принадлежит')else writeln('не принадлежит');
end.
в предыдущем решении точка лежит только на границе окружности
Не нашли ответ?
Похожие вопросы